aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-06 10:21:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-06 10:21:26 +0000
commit3d3e17a76291b9abf4ab801b79ebd9f51f8337ab (patch)
tree8f72a7f9145e8362339c9bb119eb5a47fc32cdce /package/kernel/mac80211/Makefile
parentee601f4dc9c9e88043dda4c81e6840d23ea362a2 (diff)
downloadmaster-187ad058-3d3e17a76291b9abf4ab801b79ebd9f51f8337ab.tar.gz
master-187ad058-3d3e17a76291b9abf4ab801b79ebd9f51f8337ab.tar.bz2
master-187ad058-3d3e17a76291b9abf4ab801b79ebd9f51f8337ab.zip
ath10k: remove support for the obsolete STA firmware
Current firmware should work for station mode as well, and the older firmware will usually behave worse and become unsupported over time. Also, the MAC address handling on ar71xx is only implemented on one firmware version. Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46197 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile19
1 files changed, 0 insertions, 19 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index de82118b02..f7f7401728 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -621,19 +621,6 @@ Atheros IEEE 802.11ac family of chipsets. For now only
PCI is supported.
endef
-define KernelPackage/ath10k/config
- if PACKAGE_kmod-ath10k
-
- config ATH10K_STA_FW
- bool "Firmware optimized for STA operation"
- default n
- help
- Use the ath10k firmware optimized for wireless client instead
- of access point operation.
-
- endif
-endef
-
define KernelPackage/carl9170
$(call KernelPackage/mac80211/Default)
TITLE:=Driver for Atheros AR9170 USB sticks
@@ -1858,15 +1845,9 @@ define KernelPackage/ath10k/install
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/ath10k/QCA988X/hw2.0/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
-ifeq ($(CONFIG_ATH10K_STA_FW),y)
- $(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/main/firmware-2.bin_999.999.0.636 \
- $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-2.bin
-else
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.2.4/untested/firmware-5.bin_10.2.4.70-2 \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
-endif
endef
define KernelPackage/mwl8k/install