aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-07-06 10:58:14 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-07-06 10:58:14 +0000
commit1287291e3556ca6177e6998305e2fdb614d5d271 (patch)
tree2ea9e6d7f135a6d2a86dcf8dca0153d15262bec5 /package/kernel/mac80211/Makefile
parentc697e27174d635090ea210e1a5b2de71585a7bf4 (diff)
downloadmaster-187ad058-1287291e3556ca6177e6998305e2fdb614d5d271.tar.gz
master-187ad058-1287291e3556ca6177e6998305e2fdb614d5d271.tar.bz2
master-187ad058-1287291e3556ca6177e6998305e2fdb614d5d271.zip
mac80211: b43: add support for firmware 784.2
This adds firmware 784.2 for b43 as an option. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41524 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile30
1 files changed, 22 insertions, 8 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 3f489c5cd4..20da959238 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1018,6 +1018,14 @@ endef
#Broadcom firmware
+ifneq ($(CONFIG_B43_FW_6_30),)
+ PKG_B43_FWV4_NAME:=broadcom-wl
+ PKG_B43_FWV4_VERSION:=6.30.163.46
+ PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).wl_apsta.o
+ PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).tar.bz2
+ PKG_B43_FWV4_SOURCE_URL:=http://www.lwfinger.com/b43-firmware/
+ PKG_B43_FWV4_MD5SUM:=6fe97e9368d25342a1ab943d3cf3496d
+else
ifneq ($(CONFIG_B43_FW_5_10),)
PKG_B43_FWV4_NAME:=broadcom-wl
PKG_B43_FWV4_VERSION:=5.10.56.27.3
@@ -1051,6 +1059,7 @@ else
endif
endif
endif
+endif
ifneq ($(CONFIG_B43_OPENFIRMWARE),)
PKG_B43_FWV4_NAME:=broadcom-wl
PKG_B43_FWV4_VERSION:=5.2
@@ -1125,34 +1134,39 @@ config PACKAGE_B43_USE_BCMA
config B43_FW_4_150
bool "Firmware 410.2160 from driver 4.150.10.5 (old stable)"
help
- Stable firmware for BCM43xx devices.
+ Old stable firmware for BCM43xx devices.
If unsure, select this.
config B43_FW_4_178
bool "Firmware 478.104 from driver 4.178.10.4"
help
- Experimental firmware for BCM43xx devices.
-
- This firmware is not tested as much as the "stable" firmware.
+ Older firmware for BCM43xx devices.
If unsure, select the "stable" firmware.
config B43_FW_5_10
bool "Firmware 508.1084 from driver 5.10.56.27"
help
- Newer experimental firmware for BCM43xx devices.
-
- This firmware is mostly untested. It is needed for some N-PHY devices.
+ Older firmware for BCM43xx devices.
If unsure, select the "stable" firmware.
config B43_FW_5_100_138
bool "Firmware 666.2 from driver 5.100.138 (stable)"
help
+ The currently default firmware for BCM43xx devices.
+
+ This firmware currently gets most of the testing and is needed for some N-PHY devices.
+
+ If unsure, select the this firmware.
+
+ config B43_FW_6_30
+ bool "Firmware 784.2 from driver 6.30.163.46 (experimental)"
+ help
Newer experimental firmware for BCM43xx devices.
- This firmware is mostly untested. It is needed for some N-PHY devices.
+ This firmware is mostly untested.
If unsure, select the "stable" firmware.