aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-04-04 10:16:54 +0000
committerJonas Gorski <jogo@openwrt.org>2014-04-04 10:16:54 +0000
commitfb7ad14687b728290b4ef4ceb8d83151385c7175 (patch)
treea134de6c69c5764b7151885ff15cedb7a84a3021 /package/kernel/linux
parent5e36f2963e0457c71e0db53d03f5b8626964f16b (diff)
downloadmaster-187ad058-fb7ad14687b728290b4ef4ceb8d83151385c7175.tar.gz
master-187ad058-fb7ad14687b728290b4ef4ceb8d83151385c7175.tar.bz2
master-187ad058-fb7ad14687b728290b4ef4ceb8d83151385c7175.zip
kernel: fix bluetooth and zsmalloc for 3.14
zsmalloc was promoted from staging, while bluetooth gained a dependency to a library shared with 802.15.4 for 6lowpan support. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40379 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk24
1 files changed, 23 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 406eb52b84..48294014b7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -10,10 +10,26 @@ OTHER_MENU:=Other modules
WATCHDOG_DIR:=watchdog
+define KernelPackage/6lowpan-iphc
+ USBMENU:=$(OTHER_MENU)
+ TITLE:=6lowpan shared code
+ DEPENDS:=@LINUX_3_14
+ KCONFIG:=CONFIG_6LOWPAN_IPHC
+ HIDDEN:=1
+ FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
+ AUTOLOAD:=$(call Autoprobe,6lowpan_iphc)
+endef
+
+define KernelPackage/6lowpan-iphc/description
+ Shared 6lowpan code for IEEE 802.15.4 and Bluetooth.
+endef
+
+$(eval $(call KernelPackage,6lowpan-iphc))
+
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +LINUX_3_14:kmod-6lowpan-iphc
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -707,9 +723,15 @@ define KernelPackage/zram
CONFIG_ZRAM \
CONFIG_ZRAM_DEBUG=n \
CONFIG_PGTABLE_MAPPING=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.14.0)),1)
+ FILES:=\
+ $(LINUX_DIR)/mm/zsmalloc.ko \
+ $(LINUX_DIR)/drivers/block/zram/zram.ko
+else
FILES:= \
$(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko \
$(LINUX_DIR)/drivers/staging/zram/zram.ko
+endif
AUTOLOAD:=$(call AutoLoad,20,zsmalloc zram)
endef