aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-10 19:11:09 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-10 19:11:09 +0000
commit76c7acee0b183dfa17f179869e46f058f3435460 (patch)
treee3df9e68c2b55ff52db7c183f5b63914e9a0b8a6 /package/kernel/linux
parent681c97e7011b16aacec00a854d8aac34db13b203 (diff)
downloadmaster-187ad058-76c7acee0b183dfa17f179869e46f058f3435460.tar.gz
master-187ad058-76c7acee0b183dfa17f179869e46f058f3435460.tar.bz2
master-187ad058-76c7acee0b183dfa17f179869e46f058f3435460.zip
kernel: Linux IP Virtual Server kernel modules (netfilter.mk patch)
IPVS (IP Virtual Server) implements transport-layer load balancing inside the Linux kernel so called Layer-4 switching. IPVS running on a host acts as a load balancer at the front of a cluster of real servers, it can direct requests for TCP/UDP based services to the real servers, and makes services of the real servers to appear as a virtual service on a single IP address. Signed-off-by: Mauro Mozzarelli <mauro@ezplanet.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48982 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netfilter.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index a0a19b23a9..a5220825f9 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -270,6 +270,60 @@ define KernelPackage/ipt-ipset
endef
$(eval $(call KernelPackage,ipt-ipset))
+IPVS_MODULES:= \
+ ip_vs \
+ ip_vs_lc \
+ ip_vs_wlc \
+ ip_vs_rr \
+ ip_vs_wrr \
+ ip_vs_lblc \
+ ip_vs_lblcr \
+ ip_vs_dh \
+ ip_vs_sh \
+ ip_vs_fo \
+ ip_vs_nq \
+ ip_vs_sed
+
+define KernelPackage/nf-ipvs
+ SUBMENU:=Netfilter Extensions
+ TITLE:=IP Virtual Server modules
+ DEPENDS:=+kmod-lib-crc32c
+ KCONFIG:= \
+ CONFIG_IP_VS \
+ CONFIG_IP_VS_IPV6=y \
+ CONFIG_IP_VS_DEBUG=n \
+ CONFIG_IP_VS_PROTO_TCP=y \
+ CONFIG_IP_VS_PROTO_UDP=y \
+ CONFIG_IP_VS_PROTO_AH_ESP=y \
+ CONFIG_IP_VS_PROTO_ESP=y \
+ CONFIG_IP_VS_PROTO_AH=y \
+ CONFIG_IP_VS_PROTO_SCTP=y \
+ CONFIG_IP_VS_TAB_BITS=12 \
+ CONFIG_IP_VS_RR \
+ CONFIG_IP_VS_WRR \
+ CONFIG_IP_VS_LC \
+ CONFIG_IP_VS_WLC \
+ CONFIG_IP_VS_FO \
+ CONFIG_IP_VS_OVF \
+ CONFIG_IP_VS_LBLC \
+ CONFIG_IP_VS_LBLCR \
+ CONFIG_IP_VS_DH \
+ CONFIG_IP_VS_SH \
+ CONFIG_IP_VS_SED \
+ CONFIG_IP_VS_NQ \
+ CONFIG_IP_VS_SH_TAB_BITS=8 \
+ CONFIG_IP_VS_NFCT=n \
+ CONFIG_NETFILTER_XT_MATCH_IPVS=n
+
+ FILES:=$(foreach mod,$(IPVS_MODULES),$(LINUX_DIR)/net/netfilter/ipvs/$(mod).ko)
+ $(call AddDepends/ipt,+kmod-ipt-conntrack)
+endef
+$(eval $(call KernelPackage,nf-ipvs))
+
+define KernelPackage/nf-ipvs/description
+ IPVS (IP Virtual Server) implements transport-layer load balancing inside the Linux kernel
+ so called Layer-4 switching.
+endef
define KernelPackage/ipt-nat
TITLE:=Basic NAT targets