aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:45:05 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:45:05 +0000
commit60243c285a603db135c0214ff2a97d06b64126c7 (patch)
tree6db6e00c9207d000ec4704b1857cc303d17f1d29 /package/kernel/linux
parent3a95ee11ea0e472dd1347ee68a468478a3235a47 (diff)
downloadmaster-187ad058-60243c285a603db135c0214ff2a97d06b64126c7.tar.gz
master-187ad058-60243c285a603db135c0214ff2a97d06b64126c7.tar.bz2
master-187ad058-60243c285a603db135c0214ff2a97d06b64126c7.zip
kernel: Fix xen domU kmod-xen-kbd package
modified version of http://patchwork.openwrt.org/patch/5526/ Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40941 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/virtual.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/virtual.mk b/package/kernel/linux/modules/virtual.mk
index e1bbe3f439..3a1fe006fa 100644
--- a/package/kernel/linux/modules/virtual.mk
+++ b/package/kernel/linux/modules/virtual.mk
@@ -142,8 +142,9 @@ $(eval $(call KernelPackage,xen-fbdev))
define KernelPackage/xen-kbddev
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen virtual keyboard and mouse
- DEPENDS:=@TARGET_x86_xen_domu
- KCONFIG:=CONFIG_XEN_KBDDEV_FRONTEND
+ DEPENDS:=@TARGET_x86_xen_domu +kmod-input-core
+ KCONFIG:=CONFIG_INPUT_MISC=y \
+ CONFIG_INPUT_XEN_KBDDEV_FRONTEND
FILES:=$(LINUX_DIR)/drivers/input/xen-kbdfront.ko
AUTOLOAD:=$(call AutoLoad,08,xen-kbdfront)
endef