aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-07-15 11:08:04 +0000
committerJohn Crispin <blogic@openwrt.org>2013-07-15 11:08:04 +0000
commit44bdcce3e1d5fceffc1339754fee27244c35118a (patch)
treecddab35d64cc6500d176615a4dd5cd9c0f68f62d /package/kernel/linux
parentaefdd583c9754a6f325f3abadf2c7d988a00c44b (diff)
downloadmaster-187ad058-44bdcce3e1d5fceffc1339754fee27244c35118a.tar.gz
master-187ad058-44bdcce3e1d5fceffc1339754fee27244c35118a.tar.bz2
master-187ad058-44bdcce3e1d5fceffc1339754fee27244c35118a.zip
kernel: add usb-dwc2 kmod
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37338 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 1cb8e2c1b2..0fa99ccb79 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -172,6 +172,29 @@ endef
$(eval $(call KernelPackage,usb2-pci))
+define KernelPackage/usb-dwc2
+ TITLE:=DWC2 USB controller driver
+ DEPENDS:=@LINUX_3_10
+ KCONFIG:= \
+ CONFIG_USB_DWC2 \
+ CONFIG_USB_DWC2_DEBUG=n \
+ CONFIG_USB_DWC2_VERBOSE=n \
+ CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/staging/dwc2/dwc2.ko \
+ $(LINUX_DIR)/drivers/staging/dwc2/dwc2_platform.ko
+ AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-dwc2/description
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core.
+endef
+
+$(eval $(call KernelPackage,usb-dwc2))
+
+
define KernelPackage/usb-acm
TITLE:=Support for modems/isdn controllers
KCONFIG:=CONFIG_USB_ACM