aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-16 11:12:03 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-16 11:12:03 +0000
commit0ce7f50d46531da6af9bd83375b6b7f42b2d1c67 (patch)
treed34bffdbace2f6b8da11e4cd274b62ed5890ec6b /package/kernel/linux
parent56e30206f05f211a573385c16dcfd6c296f76a14 (diff)
downloadmaster-187ad058-0ce7f50d46531da6af9bd83375b6b7f42b2d1c67.tar.gz
master-187ad058-0ce7f50d46531da6af9bd83375b6b7f42b2d1c67.tar.bz2
master-187ad058-0ce7f50d46531da6af9bd83375b6b7f42b2d1c67.zip
kernel: wpan: at86rf230 depends on regmap-spi
kmod-at86rf230 select REGMAP_SPI since 3.17, so add a dependency to kmod-regmap. Fixes the following error: Package kmod-at86rf230 is missing dependencies for the following libraries: regmap-core.ko regmap-spi.ko Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46387 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/wpan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index d4173ca4b1..1b6c826e7f 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -71,7 +71,7 @@ $(eval $(call KernelPackage,fakelb))
define KernelPackage/at86rf230
SUBMENU:=$(WPAN_MENU)
TITLE:=AT86RF230 transceiver driver
- DEPENDS:=+kmod-mac802154
+ DEPENDS:=+kmod-mac802154 +kmod-regmap
KCONFIG:=CONFIG_IEEE802154_AT86RF230 \
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y