aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-11 18:35:41 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-11 18:35:41 +0000
commit046c63d70762ac2639cf87afb44548466ad0c327 (patch)
treedf91726893c4560255387a02b0f52503dc3b34f6 /package/kernel/linux
parent154f8ef0d814635d48950de09bc169106c00e8a1 (diff)
downloadmaster-187ad058-046c63d70762ac2639cf87afb44548466ad0c327.tar.gz
master-187ad058-046c63d70762ac2639cf87afb44548466ad0c327.tar.bz2
master-187ad058-046c63d70762ac2639cf87afb44548466ad0c327.zip
kernel/modules: fix chipidea
it should needs to depend on imx and mxs also remove duplicate kmod definition from mxs target Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43627 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 4644cbbe16..c700570375 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1401,9 +1401,9 @@ endef
$(eval $(call KernelPackage,usbip-server))
-define KernelPackage/usb-chipidea
+define KernelPackage/usb-chipidea-imx
TITLE:=Support for ChipIdea controllers
- DEPENDS:=+kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
+ DEPENDS:=@TARGET_imx6||TARGET_mxs +kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
KCONFIG:=\
CONFIG_USB_CHIPIDEA \
CONFIG_USB_CHIPIDEA_HOST=y \
@@ -1424,12 +1424,12 @@ else
endif
$(call AddDepends/usb)
endef
-
-define KernelPackage/usb-chipidea/description
+
+define KernelPackage/usb-chipidea-imx/description
Kernel support for USB ChipIdea controllers
endef
-$(eval $(call KernelPackage,usb-chipidea,1))
+$(eval $(call KernelPackage,usb-chipidea-imx,1))
define KernelPackage/usb-mxs-phy