aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-03-05 17:49:09 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-03-05 17:49:09 +0000
commitb8b788475cb93fa8bd1327ff9e7467fd61dd47ae (patch)
tree201ee8796c65ec199734f3c581034c83f326688e /package/kernel/linux/modules
parentf8e83654e40b6ac89f80fac8eb30de145a12c716 (diff)
downloadmaster-187ad058-b8b788475cb93fa8bd1327ff9e7467fd61dd47ae.tar.gz
master-187ad058-b8b788475cb93fa8bd1327ff9e7467fd61dd47ae.tar.bz2
master-187ad058-b8b788475cb93fa8bd1327ff9e7467fd61dd47ae.zip
kernel: mpc85xx: fix build of kmod-usb2-fsl
Fix buildbot error for mpc85xx. ehci-fsl.ko should be packaged inside the usb2 package, because it depends on the ehci kernel module. The fsl-mph-dr-of.ko module can stay in an own package because the ehci driver depends on it. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48932 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/usb.mk19
1 files changed, 10 insertions, 9 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index d3abe18c4f..63d94bff4c 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -365,13 +365,10 @@ $(eval $(call KernelPackage,usb-ohci-pci))
define KernelPackage/usb2-fsl
TITLE:=Support for Freescale USB2 controllers
DEPENDS:=@TARGET_mpc85xx
- KCONFIG:=\
- CONFIG_USB_FSL_MPH_DR_OF \
- CONFIG_USB_EHCI_FSL
- FILES:= \
- $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko \
- $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
- AUTOLOAD:=$(call AutoLoad,39,ehci-fsl fsl-mph-dr-of,1)
+ HIDDEN:=1
+ KCONFIG:=CONFIG_USB_FSL_MPH_DR_OF
+ FILES:=$(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
+ AUTOLOAD:=$(call AutoLoad,39,fsl-mph-dr-of,1)
$(call AddDepends/usb)
endef
@@ -439,7 +436,8 @@ define KernelPackage/usb2
CONFIG_USB_OCTEON_EHCI=y \
CONFIG_USB_EHCI_HCD_ORION=y \
CONFIG_USB_EHCI_HCD_PLATFORM=y \
- CONFIG_USB_EHCI_HCD_AT91=y
+ CONFIG_USB_EHCI_HCD_AT91=y \
+ CONFIG_USB_EHCI_FSL
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
@@ -449,7 +447,10 @@ define KernelPackage/usb2
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
endif
- AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel ehci-fsl,1)
$(call AddDepends/usb)
endef