aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-11-19 12:42:00 +0000
committerJonas Gorski <jogo@openwrt.org>2014-11-19 12:42:00 +0000
commit7c7d2419a28fcafd6956ce3fa630d471a9209746 (patch)
treef5bd3ff3f3d3c5497c1655647f3d9df2e2998566 /package/kernel/linux/modules
parenta83eac388fefa884b0d9183e78036c197a756012 (diff)
downloadmaster-187ad058-7c7d2419a28fcafd6956ce3fa630d471a9209746.tar.gz
master-187ad058-7c7d2419a28fcafd6956ce3fa630d471a9209746.tar.bz2
master-187ad058-7c7d2419a28fcafd6956ce3fa630d471a9209746.zip
kernel: remove gpio-pwm kmod definition
r37490 removed the actual driver but left the kmod definition intact, causing the build system hapily creating an empty package for it. Remove it also to not make it seem as if it still exists. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43316 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index ce22819887..5d1c2fb348 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -509,22 +509,6 @@ endef
$(eval $(call KernelPackage,pwm))
-define KernelPackage/pwm-gpio
- SUBMENU:=$(OTHER_MENU)
- TITLE:=PWM over GPIO
- DEPENDS:=+kmod-pwm
- KCONFIG:=CONFIG_GPIO_PWM
- FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
- AUTOLOAD:=$(call AutoProbe,gpio-pwm)
-endef
-
-define KernelPackage/pwm-gpio/description
- Kernel module to models a single-channel PWM device using a timer and a GPIO pin
-endef
-
-$(eval $(call KernelPackage,pwm-gpio))
-
-
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support