aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/wpan.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-10 14:42:11 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-10 14:42:11 +0000
commit4efc59d4e98f5ad6590f4402988632cfb25923df (patch)
tree537ba842c610c9192dd1c4e493910159a92ccf9c /package/kernel/linux/modules/wpan.mk
parent52c0f36c88ac9e7b0574716f628e966b01ff36a1 (diff)
downloadmaster-187ad058-4efc59d4e98f5ad6590f4402988632cfb25923df.tar.gz
master-187ad058-4efc59d4e98f5ad6590f4402988632cfb25923df.tar.bz2
master-187ad058-4efc59d4e98f5ad6590f4402988632cfb25923df.zip
modules: more wpan fixes
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45365 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/wpan.mk')
-rw-r--r--package/kernel/linux/modules/wpan.mk30
1 files changed, 7 insertions, 23 deletions
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index a89f3b71fc..8b253774f7 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -9,7 +9,7 @@ WPAN_MENU:=Wireless Drivers
define KernelPackage/ieee802154
SUBMENU:=$(WPAN_MENU)
TITLE:=IEEE-802.15.4 support
- DEPENDS:=@!LINUX_4.0
+ DEPENDS:=@LINUX_4_0
KCONFIG:= \
CONFIG_IEEE802154 \
CONFIG_IEEE802154_SOCKET=y
@@ -32,11 +32,11 @@ $(eval $(call KernelPackage,ieee802154))
define KernelPackage/mac802154
SUBMENU:=$(WPAN_MENU)
TITLE:=MAC-802.15.4 support
- DEPENDS:=@!LINUX_4.0
+ DEPENDS:=@LINUX_4_0
KCONFIG:= \
CONFIG_MAC802154 \
CONFIG_IEEE802154_DRIVERS=y
- DEPENDS:=+kmod-ieee802154 +kmod-crypto-aead +kmod-lib-crc-ccitt @!LINUX_4.0
+ DEPENDS:=+kmod-ieee802154 +kmod-crypto-aead +kmod-lib-crc-ccitt @LINUX_4_0
FILES:=$(LINUX_DIR)/net/mac802154/mac802154.ko
AUTOLOAD:=$(call AutoLoad,91,mac802154)
endef
@@ -53,26 +53,10 @@ endef
$(eval $(call KernelPackage,mac802154))
-define KernelPackage/fakehard
- SUBMENU:=$(WPAN_MENU)
- TITLE:=Fake LR-WPAN driver
- DEPENDS:=+kmod-mac802154 @!LINUX_4.0
- KCONFIG:=CONFIG_IEEE802154_FAKEHARD
- FILES:=$(LINUX_DIR)/drivers/net/ieee802154/fakehard.ko
- AUTOLOAD:=$(call AutoLoad,92,fakehard)
-endef
-
-define KernelPackage/fakehard/description
- Say Y here to enable the fake driver that can emulate a net
- of several interconnected radio devices.
-endef
-
-$(eval $(call KernelPackage,fakehard))
-
define KernelPackage/fakelb
SUBMENU:=$(WPAN_MENU)
- TITLE:=Fake LR-WPAN loopback driver
- DEPENDS:=+kmod-mac802154 @!LINUX_4.0
+ TITLE:=Fake LR-WPAN driver
+ DEPENDS:=+kmod-mac802154 @LINUX_4_0
KCONFIG:=CONFIG_IEEE802154_FAKELB
FILES:=$(LINUX_DIR)/drivers/net/ieee802154/fakelb.ko
AUTOLOAD:=$(call AutoLoad,92,fakelb)
@@ -124,9 +108,9 @@ $(eval $(call KernelPackage,cc2520))
define KernelPackage/ieee802154_6lowpan
SUBMENU:=$(WPAN_MENU)
TITLE:= 6LoWPAN support over IEEE-802.15.4
- DEPENDS:=@!LINUX_4.0
+ DEPENDS:=@LINUX_4_0
KCONFIG:=CONFIG_IEEE802154_6LOWPAN
- DEPENDS:=@!LINUX_4.0
+ DEPENDS:=@LINUX_4_0
FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko
AUTOLOAD:=$(call AutoLoad,91,ieee802154_6lowpan)
endef