aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/wpan.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-25 12:41:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-25 12:41:19 +0000
commit4a3f5f8b652f48112507a5e5a72f793980834a39 (patch)
tree985326a7474325ea01c1e05619fc89c964e05b30 /package/kernel/linux/modules/wpan.mk
parent5d1abd7bfa82e1e0f8e4e5ca7baebeb2cb691cb4 (diff)
downloadmaster-187ad058-4a3f5f8b652f48112507a5e5a72f793980834a39.tar.gz
master-187ad058-4a3f5f8b652f48112507a5e5a72f793980834a39.tar.bz2
master-187ad058-4a3f5f8b652f48112507a5e5a72f793980834a39.zip
kernel: wpan: mrf24j40 depends on regmap-spi
kmod-mrf24j40 select REGMAP_SPI since 4.3, thus add dependency to kmod-regmap. Found by buildbot: Package kmod-mrf24j40 is missing dependencies for the following libraries: regmap-spi.ko Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48484 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/wpan.mk')
-rw-r--r--package/kernel/linux/modules/wpan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index 58fe8eb9d8..199044fc33 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -85,7 +85,7 @@ $(eval $(call KernelPackage,at86rf230))
define KernelPackage/mrf24j40
SUBMENU:=$(WPAN_MENU)
TITLE:=MRF24J40 transceiver driver
- DEPENDS:=+kmod-mac802154
+ DEPENDS:=+kmod-mac802154 +kmod-regmap
KCONFIG:=CONFIG_IEEE802154_MRF24J40 \
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y