aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-21 15:37:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-21 15:37:38 +0000
commit54e32dab8c148730033a95a41a5236c45b1629c8 (patch)
tree84751a0d2fa113c804f3b587014e4eeb57718a41 /package/kernel/linux/modules/video.mk
parent647406c825c89c25373d6dec0874f4a360ca071b (diff)
downloadmaster-187ad058-54e32dab8c148730033a95a41a5236c45b1629c8.tar.gz
master-187ad058-54e32dab8c148730033a95a41a5236c45b1629c8.tar.bz2
master-187ad058-54e32dab8c148730033a95a41a5236c45b1629c8.zip
kernel: make backlight support depend on display support
Mark backlight core package as hidden Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48437 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 6925e80e1c..81e7e42b73 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -18,6 +18,8 @@ V4L2_USB_DIR=usb
define KernelPackage/backlight
SUBMENU:=$(VIDEO_MENU)
TITLE:=Backlight support
+ DEPENDS:=@DISPLAY_SUPPORT
+ HIDDEN:=1
KCONFIG:=CONFIG_BACKLIGHT_CLASS_DEVICE=m \
CONFIG_BACKLIGHT_LCD_SUPPORT=y \
CONFIG_LCD_CLASS_DEVICE=n \
@@ -39,7 +41,7 @@ $(eval $(call KernelPackage,backlight))
define KernelPackage/backlight-pwm
SUBMENU:=$(VIDEO_MENU)
TITLE:=PWM Backlight support
- DEPENDS:=+kmod-pwm kmod-backlight
+ DEPENDS:=+kmod-pwm +kmod-backlight
KCONFIG:=CONFIG_BACKLIGHT_PWM=m
FILES:=$(LINUX_DIR)/drivers/video/backlight/pwm_bl.ko
AUTOLOAD:=$(call AutoProbe,video pwm_bl)