aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-21 15:37:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-21 15:37:01 +0000
commit3e7e16ac94aba4671be607074b6c3da3c4448ae7 (patch)
tree5d3e90c10d0a78918da3cc5396cc11c2036d66e1 /package/kernel/linux/modules/video.mk
parenta64075a458d91f04340cf5202162ee4e1adacc06 (diff)
downloadmaster-187ad058-3e7e16ac94aba4671be607074b6c3da3c4448ae7.tar.gz
master-187ad058-3e7e16ac94aba4671be607074b6c3da3c4448ae7.tar.bz2
master-187ad058-3e7e16ac94aba4671be607074b6c3da3c4448ae7.zip
kernel: video: add fbcon support
Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48433 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk49
1 files changed, 48 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 61d7d88497..cece87612f 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -61,7 +61,10 @@ define KernelPackage/fb
SUBMENU:=$(VIDEO_MENU)
TITLE:=Framebuffer support
DEPENDS:=@DISPLAY_SUPPORT
- KCONFIG:=CONFIG_FB
+ KCONFIG:= \
+ CONFIG_FB \
+ CONFIG_FB_MXS=n \
+ CONFIG_FB_SM750=n
FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/fb.ko
AUTOLOAD:=$(call AutoLoad,06,fb)
endef
@@ -77,6 +80,50 @@ endef
$(eval $(call KernelPackage,fb))
+
+define KernelPackage/fbcon
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=Framebuffer Console support
+ DEPENDS:=+kmod-fb
+ KCONFIG:= \
+ CONFIG_FRAMEBUFFER_CONSOLE \
+ CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y \
+ CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y \
+ CONFIG_FONTS=y \
+ CONFIG_FONT_8x8=y \
+ CONFIG_FONT_8x16=y \
+ CONFIG_FONT_6x11=n \
+ CONFIG_FONT_7x14=n \
+ CONFIG_FONT_PEARL_8x8=n \
+ CONFIG_FONT_ACORN_8x8=n \
+ CONFIG_FONT_MINI_4x6=n \
+ CONFIG_FONT_6x10=n \
+ CONFIG_FONT_SUN8x16=n \
+ CONFIG_FONT_SUN12x22=n \
+ CONFIG_FONT_10x18=n \
+ CONFIG_VT=y \
+ CONFIG_CONSOLE_TRANSLATIONS=y \
+ CONFIG_VT_CONSOLE=y \
+ CONFIG_VT_HW_CONSOLE_BINDING=y
+ $(call AddDepends/fb)
+ FILES:= \
+ $(LINUX_DIR)/drivers/video/console/bitblit.ko \
+ $(LINUX_DIR)/drivers/video/console/softcursor.ko \
+ $(LINUX_DIR)/drivers/video/console/fbcon.ko \
+ $(LINUX_DIR)/drivers/video/console/fbcon_rotate.ko \
+ $(LINUX_DIR)/drivers/video/console/fbcon_cw.ko \
+ $(LINUX_DIR)/drivers/video/console/fbcon_ud.ko \
+ $(LINUX_DIR)/drivers/video/console/fbcon_ccw.ko \
+ $(LINUX_DIR)/lib/fonts/font.ko
+ AUTOLOAD:=$(call AutoLoad,94,font softcursor tileblit fbcon_cw fbcon_ud fbcon_ccw fbcon_rotate bitblit fbcon)
+endef
+
+define KernelPackage/fbcon/description
+ Kernel support for framebuffer console
+endef
+
+$(eval $(call KernelPackage,fbcon))
+
define KernelPackage/fb-cfb-fillrect
SUBMENU:=$(VIDEO_MENU)
TITLE:=Framebuffer software rectangle filling support