aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-02 14:31:10 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-02 14:31:10 +0000
commite6471f2b603759c30859906b567224d59267ac3d (patch)
tree93cb8fef17b9ef9d4d94d2467474beec5b060da6 /package/kernel/linux/modules/usb.mk
parentec91d8a6540cbce79ab181bf152e1e392a62ca18 (diff)
downloadmaster-187ad058-e6471f2b603759c30859906b567224d59267ac3d.tar.gz
master-187ad058-e6471f2b603759c30859906b567224d59267ac3d.tar.bz2
master-187ad058-e6471f2b603759c30859906b567224d59267ac3d.zip
kernel: add garmin_gps module
OpenWrt on sailboats requested: https://forum.openwrt.org/viewtopic.php?id=56586 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45232 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index e3d7165f47..fc47568dbc 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -631,6 +631,21 @@ endef
$(eval $(call KernelPackage,usb-serial-ftdi))
+define KernelPackage/usb-serial-garmin
+ TITLE:=Support for Garmin GPS devices
+ KCONFIG:=CONFIG_USB_SERIAL_GARMIN
+ FILES:=$(LINUX_DIR)/drivers/usb/serial/garmin_gps.ko
+ AUTOLOAD:=$(call AutoProbe,garmin_gps)
+ $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-garmin/description
+ Should work with most Garmin GPS devices which have a native USB port.
+endef
+
+$(eval $(call KernelPackage,usb-serial-garmin))
+
+
define KernelPackage/usb-serial-ti-usb
TITLE:=Support for TI USB 3410/5052
KCONFIG:=CONFIG_USB_SERIAL_TI