aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-25 16:30:52 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-25 16:30:52 +0000
commitde888b8dd44a01af43bd462798f4c77bbe21d4f6 (patch)
tree4f8fac61ebc006bf4420c559981b8dd22f66d40b /package/kernel/linux/modules/usb.mk
parent028ad9f1cdee8e67a2d4a52c938f0a77ab9aed3d (diff)
downloadmaster-187ad058-de888b8dd44a01af43bd462798f4c77bbe21d4f6.tar.gz
master-187ad058-de888b8dd44a01af43bd462798f4c77bbe21d4f6.tar.bz2
master-187ad058-de888b8dd44a01af43bd462798f4c77bbe21d4f6.zip
kernel: add ohci-platform.ko for 3.11+
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42288 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 96c899a8dd..0b5abdc335 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -331,7 +331,10 @@ define KernelPackage/usb-ohci
CONFIG_USB_OHCI_HCD_OMAP3=y \
CONFIG_USB_OHCI_HCD_PLATFORM=y
FILES:=$(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko
- AUTOLOAD:=$(call AutoLoad,50,ohci-hcd,1)
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.11.0)),1)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
+endif
+ AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
$(call AddDepends/usb)
endef