aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-06-15 22:11:50 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-06-15 22:11:50 +0000
commitc6917af6b1ffea38d2483d90d161587745000e67 (patch)
treecebb196dd2dcf8a8fb7bb67c02d76d6c73e85398 /package/kernel/linux/modules/usb.mk
parenta0fd6f26d6456cc3ba070e14103afd73c1ba2cf4 (diff)
downloadmaster-187ad058-c6917af6b1ffea38d2483d90d161587745000e67.tar.gz
master-187ad058-c6917af6b1ffea38d2483d90d161587745000e67.tar.bz2
master-187ad058-c6917af6b1ffea38d2483d90d161587745000e67.zip
kernel: use bcma-hcd.ko on bcm53xx for ohci
On bcm53xx we still need usb-ohci to support USB 1.1 devices and it obviously needs bcma-hcd.ko that will init controller and register platform device. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45994 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 68f22cc05b..f27fcbd47f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -300,6 +300,7 @@ $(eval $(call KernelPackage,usb-uhci,1))
define KernelPackage/usb-ohci
TITLE:=Support for OHCI controllers
DEPENDS:= \
+ +TARGET_bcm53xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-ssb
KCONFIG:= \