aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-02-09 14:08:10 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-02-09 14:08:10 +0000
commitc59ada3e1d9fea16be47b1ac29f13e555da6a8a2 (patch)
tree7363f8e42b4a110dd5b0630574200a6d24aead6b /package/kernel/linux/modules/usb.mk
parent12f04cad01df10964913c0188258d6cdf4bff928 (diff)
downloadmaster-187ad058-c59ada3e1d9fea16be47b1ac29f13e555da6a8a2.tar.gz
master-187ad058-c59ada3e1d9fea16be47b1ac29f13e555da6a8a2.tar.bz2
master-187ad058-c59ada3e1d9fea16be47b1ac29f13e555da6a8a2.zip
[usb]: use musb in PIO mode, as DMA support is platform dependent
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39549 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 5fd263567f..15133a81c2 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -40,7 +40,9 @@ define KernelPackage/musb-hdrc
TITLE:=Support for Mentor Graphics silicon dual role USB
KCONFIG:= \
CONFIG_USB_MUSB_HDRC \
- CONFIG_MUSB_PIO_ONLY=n \
+ CONFIG_USB_INVENTRA_DMA=n \
+ CONFIG_USB_TI_CPPI41_DMA=n \
+ CONFIG_MUSB_PIO_ONLY=y \
CONFIG_USB_MUSB_DUAL_ROLE=y \
CONFIG_USB_MUSB_GADGET=n \
CONFIG_USB_MUSB_HOST=n \