aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-07-04 01:24:37 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-07-04 01:24:37 +0000
commitb6a3254a94d37ec1311b2f3ca22f4a78a50bf5ea (patch)
treeac2991957ee87937469172990996b5493f66435d /package/kernel/linux/modules/usb.mk
parent1074a4ce2f0d69aa9c3d326ff1b575b924edec6e (diff)
downloadmaster-187ad058-b6a3254a94d37ec1311b2f3ca22f4a78a50bf5ea.tar.gz
master-187ad058-b6a3254a94d37ec1311b2f3ca22f4a78a50bf5ea.tar.bz2
master-187ad058-b6a3254a94d37ec1311b2f3ca22f4a78a50bf5ea.zip
kernel: fix OHCI and EHCI modules for AT91
We were not copying the additional files needed to get USB to work on the AT91 platforms, make sure we do this. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46172 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 446a92aca8..8f6013c3db 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -315,7 +315,10 @@ define KernelPackage/usb-ohci
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
- AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ohci-at91.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-at91.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform ohci-at91,1)
$(call AddDepends/usb)
endef
@@ -416,14 +419,18 @@ define KernelPackage/usb2
CONFIG_USB_EHCI_MXC=y \
CONFIG_USB_OCTEON_EHCI=y \
CONFIG_USB_EHCI_HCD_ORION=y \
- CONFIG_USB_EHCI_HCD_PLATFORM=y
+ CONFIG_USB_EHCI_HCD_PLATFORM=y \
+ CONFIG_USB_EHCI_HCD_AT91=y
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
endif
- AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
$(call AddDepends/usb)
endef