aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-31 13:55:51 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-31 13:55:51 +0000
commita3626aca95c5ec865a53b8bce2f739c77c3247da (patch)
tree8772bdd7f708edc9064faf85d4b2a05590aebce1 /package/kernel/linux/modules/usb.mk
parent6e4e42727b34f890c9f37198b3ca1f32d6881466 (diff)
downloadmaster-187ad058-a3626aca95c5ec865a53b8bce2f739c77c3247da.tar.gz
master-187ad058-a3626aca95c5ec865a53b8bce2f739c77c3247da.tar.bz2
master-187ad058-a3626aca95c5ec865a53b8bce2f739c77c3247da.zip
linux: convert CompareKernelPatchVer to version tagged symbols
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44229 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index c86470059e..9dbf06264b 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -16,15 +16,10 @@ define KernelPackage/usb-core
TITLE:=Support for USB
DEPENDS:=@USB_SUPPORT
KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
FILES:= \
$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
- $(LINUX_DIR)/drivers/usb/common/usb-common.ko
-else
- FILES:= \
- $(LINUX_DIR)/drivers/usb/core/usbcore.ko \
- $(LINUX_DIR)/drivers/usb/usb-common.ko
-endif
+ $(LINUX_DIR)/drivers/usb/usb-common.ko@lt3.16 \
+ $(LINUX_DIR)/drivers/usb/common/usb-common.ko@ge3.16
AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
$(call AddDepends/nls)
endef