aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-04 05:20:34 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-04 05:20:34 +0000
commit5951971c18eeb97e1b635d01127632128f6368d5 (patch)
tree53af04311fe237dcd3c7205a011e416bca39a67c /package/kernel/linux/modules/usb.mk
parent53e7f4a54a5ab6961594e57aa1660c6e64bf87b6 (diff)
downloadmaster-187ad058-5951971c18eeb97e1b635d01127632128f6368d5.tar.gz
master-187ad058-5951971c18eeb97e1b635d01127632128f6368d5.tar.bz2
master-187ad058-5951971c18eeb97e1b635d01127632128f6368d5.zip
kernel: fix dwc3 symbols
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45268 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 46cd382aed..95ccb8422b 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -497,6 +497,9 @@ define KernelPackage/usb-dwc3
TITLE:=DWC3 USB controller driver
KCONFIG:= \
CONFIG_USB_DWC3 \
+ CONFIG_USB_DWC3_HOST=y \
+ CONFIG_USB_DWC3_GADGET=n \
+ CONFIG_USB_DWC3_DUAL_ROLE=n \
CONFIG_USB_DWC3_DEBUG=n \
CONFIG_USB_DWC3_VERBOSE=n
FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3.ko