aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-03 05:49:34 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-03 05:49:34 +0000
commit3c1eb056fbc2cb0c25d1fdcacbc2c93fdfacd669 (patch)
tree2d535b707046c8f068bdb61442f175be15988d98 /package/kernel/linux/modules/usb.mk
parentbbf2911c5cb38b1e78d9e350d57881759046faac (diff)
downloadmaster-187ad058-3c1eb056fbc2cb0c25d1fdcacbc2c93fdfacd669.tar.gz
master-187ad058-3c1eb056fbc2cb0c25d1fdcacbc2c93fdfacd669.tar.bz2
master-187ad058-3c1eb056fbc2cb0c25d1fdcacbc2c93fdfacd669.zip
kernel: fix kernel build for chipidea w/o usb-gadget
This resolves a module dependency kernel regression in r40905 with the usb-chipidea module if usb-gadget was not selected. Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40992 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 10b89da715..1fd4ddc427 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1373,10 +1373,10 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
else
FILES:=\
$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko \
- $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/gadget/udc-core.ko) \
+ $(if $(CONFIG_USB_GADGET),$(LINUX_DIR)/drivers/usb/gadget/udc-core.ko) \
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko) \
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko)
- AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imxudc-core),1)
+ AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imx),1)
endif
$(call AddDepends/usb)
endef