aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:42:41 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:42:41 +0000
commit28d6ba06c2f2419177ceac8d87d258ffee5bb5c8 (patch)
tree6ecec9e62d9012241f23d61a6d3a0fd6207914f7 /package/kernel/linux/modules/usb.mk
parent02219ea173927294b2a53e5a642bcd7c1c1070c2 (diff)
downloadmaster-187ad058-28d6ba06c2f2419177ceac8d87d258ffee5bb5c8.tar.gz
master-187ad058-28d6ba06c2f2419177ceac8d87d258ffee5bb5c8.tar.bz2
master-187ad058-28d6ba06c2f2419177ceac8d87d258ffee5bb5c8.zip
kernel: usb.mk: enable chipidea udc mode
The chipidea USB OTG controller is dual-role and supports both host and device modes. Enable device mode. Tested on Gateworks Ventana imx6 board with g_ether. Are there any other targets out there that use the CHIPIDEA controller? If so testing is needed for those. Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 096d55aa8e..e137515487 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1336,7 +1336,7 @@ define KernelPackage/usb-chipidea
KCONFIG:=\
CONFIG_USB_CHIPIDEA \
CONFIG_USB_CHIPIDEA_HOST=y \
- CONFIG_USB_CHIPIDEA_UDC=n \
+ CONFIG_USB_CHIPIDEA_UDC=y \
CONFIG_USB_CHIPIDEA_DEBUG=y
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
FILES:=\
@@ -1347,9 +1347,10 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
else
FILES:=\
$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko \
+ $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/gadget/udc-core.ko) \
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko) \
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko)
- AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imx),1)
+ AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imxudc-core),1)
endif
$(call AddDepends/usb)
endef