aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/spi.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-05-20 04:50:34 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-05-20 04:50:34 +0000
commit7fc54f8fb7f04ce8a44ba2313751ad32712f9c96 (patch)
tree8ef142991775d21db96d1aab0ec19384c21a25ca /package/kernel/linux/modules/spi.mk
parentdfcb7cbb0c2c326f82b4c6d4256f50317b2f531e (diff)
downloadmaster-187ad058-7fc54f8fb7f04ce8a44ba2313751ad32712f9c96.tar.gz
master-187ad058-7fc54f8fb7f04ce8a44ba2313751ad32712f9c96.tar.bz2
master-187ad058-7fc54f8fb7f04ce8a44ba2313751ad32712f9c96.zip
kernel: Enable CONFIG_SPI_SPIDEV when selecting kmod-spidev
Without this patch /dev/spidev*.* only appears if CONFIG_SPI_SPIDEV is manually selected and set to "y" from the kernel config. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40784 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/spi.mk')
-rw-r--r--package/kernel/linux/modules/spi.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index 1c2a789fed..c54dcc2d2a 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -77,7 +77,7 @@ $(eval $(call KernelPackage,spi-gpio))
define KernelPackage/spi-dev
SUBMENU:=$(SPI_MENU)
TITLE:=User mode SPI device driver
- KCONFIG:=CONFIG_SPI_SPIDEV \
+ KCONFIG:=CONFIG_SPI_SPIDEV=y \
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
FILES:=$(LINUX_DIR)/drivers/spi/spidev.ko