aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/spi.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
committerJohn Crispin <blogic@openwrt.org>2013-09-17 21:45:17 +0000
commit751f92881546b07452e922ad15be9d446f23f592 (patch)
tree2659076169733540dabefd531b086be6ce69f345 /package/kernel/linux/modules/spi.mk
parenta1d883cc85daebe3acdcbb5e61183db57040d02a (diff)
downloadmaster-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.gz
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.tar.bz2
master-187ad058-751f92881546b07452e922ad15be9d446f23f592.zip
kernel: make most modules use AutoProbe
now that we have modprobe we can set more than half of the modules to AutoProbe Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38021 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/spi.mk')
-rw-r--r--package/kernel/linux/modules/spi.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index cae6bc632f..1c2a789fed 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -17,7 +17,7 @@ define KernelPackage/mmc-spi
FILES:=\
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/mmc/host/of_mmc_spi.ko) \
$(LINUX_DIR)/drivers/mmc/host/mmc_spi.ko
- AUTOLOAD:=$(call AutoLoad,90,$(if $(CONFIG_OF),of_mmc_spi) mmc_spi)
+ AUTOLOAD:=$(call AutoProbe,$(if $(CONFIG_OF),of_mmc_spi) mmc_spi)
endef
define KernelPackage/mmc-spi/description
@@ -34,7 +34,6 @@ define KernelPackage/spi-bitbang
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
FILES:=$(LINUX_DIR)/drivers/spi/spi-bitbang.ko
- AUTOLOAD:=$(call AutoLoad,91,spi-bitbang)
endef
define KernelPackage/spi-bitbang/description
@@ -50,7 +49,7 @@ define KernelPackage/spi-gpio-old
DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
KCONFIG:=CONFIG_SPI_GPIO_OLD
FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio_old.ko
- AUTOLOAD:=$(call AutoLoad,92,spi_gpio_old)
+ AUTOLOAD:=$(call AutoProbe,spi_gpio_old)
endef
define KernelPackage/spi-gpio-old/description
@@ -66,7 +65,7 @@ define KernelPackage/spi-gpio
DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
KCONFIG:=CONFIG_SPI_GPIO
FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
- AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
+ AUTOLOAD:=$(call AutoProbe,spi-gpio)
endef
define KernelPackage/spi-gpio/description
@@ -82,7 +81,7 @@ define KernelPackage/spi-dev
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
FILES:=$(LINUX_DIR)/drivers/spi/spidev.ko
- AUTOLOAD:=$(call AutoLoad,93,spidev)
+ AUTOLOAD:=$(call AutoProbe,spidev)
endef
define KernelPackage/spi-dev/description