aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/spi.mk
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2016-06-30 23:50:36 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-30 23:50:36 +0200
commit3f486af5d598de94488d97fc1e449fe64915fbd4 (patch)
treea366888b2de5fc5b5751810b0cbf3d07bc1e5e95 /package/kernel/linux/modules/spi.mk
parenta244a11be90e6cd9d66bd1dc1cc35668288c88b1 (diff)
downloadmaster-187ad058-3f486af5d598de94488d97fc1e449fe64915fbd4.tar.gz
master-187ad058-3f486af5d598de94488d97fc1e449fe64915fbd4.tar.bz2
master-187ad058-3f486af5d598de94488d97fc1e449fe64915fbd4.zip
kernel/spi: add kernel package for spi-omap-24xx
spi-omap-24xx can be found in TI based SoC like the beaglebone black Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/kernel/linux/modules/spi.mk')
-rw-r--r--package/kernel/linux/modules/spi.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index 1c2a789fed..b16e26ef04 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -89,3 +89,20 @@ define KernelPackage/spi-dev/description
endef
$(eval $(call KernelPackage,spi-dev))
+
+define KernelPackage/spi-omap-24xx
+ SUBMENU:=$(SPI_MENU)
+ TITLE:=SPI omap 24xx
+ DEPENDS:=@(TARGET_omap24xx||TARGET_omap)
+ KCONFIG:=CONFIG_SPI_OMAP24XX \
+ CONFIG_SPI=y \
+ CONFIG_SPI_MASTER=y
+ FILES:=$(LINUX_DIR)/drivers/spi/spi-omap2-mcspi.ko
+ AUTOLOAD:=$(call AutoProbe,spi-omap2-mcspi)
+endef
+
+define KernelPackage/spi-dev/description
+ This package contains the user mode SPI device driver
+endef
+
+$(eval $(call KernelPackage,spi-omap-24xx))