aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-05-23 15:28:36 +0000
committerJohn Crispin <blogic@openwrt.org>2015-05-23 15:28:36 +0000
commitd4c2bebe5e79e5419bc1b95319557a96c357589c (patch)
treead44b22d234c879136213e84a2fb74d8b448a2b6 /package/kernel/linux/modules/sound.mk
parent65092c70a3cc435a8d658762102bfb3956bddb78 (diff)
downloadmaster-187ad058-d4c2bebe5e79e5419bc1b95319557a96c357589c.tar.gz
master-187ad058-d4c2bebe5e79e5419bc1b95319557a96c357589c.tar.bz2
master-187ad058-d4c2bebe5e79e5419bc1b95319557a96c357589c.zip
modules/sound: cleanup by removing unsupported Kernel cases
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45735 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 54bc30ac32..3cf9834ebc 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -32,21 +32,11 @@ SOUNDCORE_FILES ?= \
$(LINUX_DIR)/sound/core/oss/snd-pcm-oss.ko \
$(LINUX_DIR)/sound/core/snd-compress.ko
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
SOUNDCORE_LOAD += \
$(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
SOUNDCORE_FILES += \
$(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
-endif
-
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.14.0)),1)
-SOUNDCORE_LOAD += \
- snd-page-alloc
-
-SOUNDCORE_FILES += \
- $(LINUX_DIR)/sound/core/snd-page-alloc.ko
-endif
define KernelPackage/sound-core
SUBMENU:=$(SOUND_MENU)