aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-07-15 23:18:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-07-15 23:18:34 +0000
commita5282371fc6336f81ee9fed8ea6ea3e0b877757f (patch)
tree97bec27de088f5f5144acc5099483af1ab88fecc /package/kernel/linux/modules/sound.mk
parent5027ccf07620c1e6322b51afcb809b5ce6b2a5b9 (diff)
downloadmaster-187ad058-a5282371fc6336f81ee9fed8ea6ea3e0b877757f.tar.gz
master-187ad058-a5282371fc6336f81ee9fed8ea6ea3e0b877757f.tar.bz2
master-187ad058-a5282371fc6336f81ee9fed8ea6ea3e0b877757f.zip
kernel: add sound-soc-imx-sgtl5000
Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37360 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 74de21f2ad..ca5b5d236c 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -201,6 +201,22 @@ endef
$(eval $(call KernelPackage,sound-soc-imx))
+define KernelPackage/sound-soc-imx-sgtl5000
+ TITLE:=IMX SoC support for SGTL5000
+ KCONFIG:=CONFIG_SND_SOC_IMX_SGTL5000
+ FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-sgtl5000.ko
+ AUTOLOAD:=$(call AutoLoad,57,snd-soc-sgtl5000)
+ DEPENDS:=@TARGET_imx6 +kmod-sound-soc-imx
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-imx-sgtl5000/description
+ support for i.MX6 Platform sound SGTL5000 codec
+endef
+
+$(eval $(call KernelPackage,sound-soc-imx-sgtl5000))
+
+
define KernelPackage/sound-soc-gw_avila
TITLE:=Gateworks Avila SoC sound support
KCONFIG:= \