aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-26 11:54:15 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-26 11:54:15 +0000
commit9b8056164e23dfd71026bf55553e7d7a7ca8cc21 (patch)
tree72fda8781698cfbeca4479ef7e0ec34cf1264cf7 /package/kernel/linux/modules/sound.mk
parent3f0e44d0d90938280442144b1ce9a8068c956efe (diff)
downloadmaster-187ad058-9b8056164e23dfd71026bf55553e7d7a7ca8cc21.tar.gz
master-187ad058-9b8056164e23dfd71026bf55553e7d7a7ca8cc21.tar.bz2
master-187ad058-9b8056164e23dfd71026bf55553e7d7a7ca8cc21.zip
modules: package VIA AC97 modules
Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47274 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index ab83103b49..603bb7045c 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -99,6 +99,23 @@ endef
$(eval $(call KernelPackage,ac97))
+define KernelPackage/sound-mpu401
+ TITLE:=MPU-401 uart driver
+ KCONFIG:=CONFIG_SND_MPU401_UART
+ FILES:= \
+ $(LINUX_DIR)/sound/drivers/mpu401/snd-mpu401-uart.ko
+ AUTOLOAD:=$(call AutoLoad,35,snd-mpu401-uart)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-mpu401/description
+ support for MIDI ports compatible with the Roland MPU-401
+ interface in UART mode.
+endef
+
+$(eval $(call KernelPackage,sound-mpu401))
+
+
define KernelPackage/sound-seq
TITLE:=Sequencer support
FILES:= \
@@ -134,6 +151,23 @@ endef
$(eval $(call KernelPackage,sound-i8x0))
+define KernelPackage/sound-via82xx
+ TITLE:=VIA 82xx AC97 Controller
+ DEPENDS:=+kmod-ac97 +kmod-sound-mpu401
+ KCONFIG:=CONFIG_SND_VIA82XX
+ FILES:=$(LINUX_DIR)/sound/pci/snd-via82xx.ko
+ AUTOLOAD:=$(call AutoLoad,36,snd-via82xx)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-via82xx/description
+ support for the integrated AC97 sound device on motherboards
+ with VIA chipsets.
+endef
+
+$(eval $(call KernelPackage,sound-via82xx))
+
+
define KernelPackage/sound-soc-core
TITLE:=SoC sound support
DEPENDS:=+kmod-regmap +kmod-ac97