aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-11 15:05:53 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-11 15:05:53 +0000
commit7e6cf3b5feba5f96d7694498dfbf58e40e8eed29 (patch)
treea0af0a3e24ffe499c8d727690091978ba67896af /package/kernel/linux/modules/sound.mk
parent07e3cc472ab39fdd1597e522d9a3b1a51f71e69c (diff)
downloadmaster-187ad058-7e6cf3b5feba5f96d7694498dfbf58e40e8eed29.tar.gz
master-187ad058-7e6cf3b5feba5f96d7694498dfbf58e40e8eed29.tar.bz2
master-187ad058-7e6cf3b5feba5f96d7694498dfbf58e40e8eed29.zip
kernel: Add dummy sound driver
Useful when using sound players that can send to icecast, etc. without any sound device attached. Signed-off-by: Ted Hess <thess@kitschensync.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47852 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 603bb7045c..d09cf21aba 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -273,3 +273,19 @@ define KernelPackage/pcspkr/description
endef
$(eval $(call KernelPackage,pcspkr))
+
+define KernelPackage/sound-dummy
+ $(call AddDepends/sound)
+ TITLE:=Null sound output driver (sink)
+ KCONFIG:= \
+ CONFIG_SND_DUMMY
+ FILES:= \
+ $(LINUX_DIR)/sound/drivers/snd-dummy.ko
+ AUTOLOAD:=$(call AutoLoad,32,snd-dummy)
+endef
+
+define KernelPackage/sound_dummy/description
+ Dummy sound device for Alsa when no hardware present
+endef
+
+$(eval $(call KernelPackage,sound-dummy))