aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-11-25 14:09:48 +0000
committerJohn Crispin <blogic@openwrt.org>2013-11-25 14:09:48 +0000
commit77bba4261a68be8fabafe35c317ad1333f74318c (patch)
tree3cd6e310fd6b4d1f81a6acef3add8688296a909d /package/kernel/linux/modules/sound.mk
parent9706d908255dee69b2830b4a8ed8070e3d7a7604 (diff)
downloadmaster-187ad058-77bba4261a68be8fabafe35c317ad1333f74318c.tar.gz
master-187ad058-77bba4261a68be8fabafe35c317ad1333f74318c.tar.bz2
master-187ad058-77bba4261a68be8fabafe35c317ad1333f74318c.zip
kernel/modules: snd-pcm-dmaengine only if CONFIG_SND_DMAENGINE_PCM is set
Platforms without in-soc audio don't provide CONFIG_SND_DMAENGINE_PCM, thus the module is not generated. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38913 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 4e1a656dd2..bed2e3c802 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -42,10 +42,10 @@ endif
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
SOUNDCORE_LOAD += \
- snd-pcm-dmaengine
+ $(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
SOUNDCORE_FILES += \
- $(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko
+ $(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
endif
define KernelPackage/sound-core