aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-21 06:59:10 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-21 06:59:10 +0000
commitf102202ffc57bcd4f5ef0097e5d746ceea5350be (patch)
tree97a125daddc3b56195b26ccbff489518d7f68126 /package/kernel/linux/modules/other.mk
parent325bc988756e8ecb159c6e0a06d8dad631cac6e7 (diff)
downloadmaster-187ad058-f102202ffc57bcd4f5ef0097e5d746ceea5350be.tar.gz
master-187ad058-f102202ffc57bcd4f5ef0097e5d746ceea5350be.tar.bz2
master-187ad058-f102202ffc57bcd4f5ef0097e5d746ceea5350be.zip
wpan: rework bluetooth / wpan and 6lowpan dependencies
- remove/rename of 6lowpan-iphc upstream change in 3.17: 6lowpan: introduce new net/6lowpan directory id: 2c6bed7cfcd3f594ed9e4d6919fa2ebea2243d19 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45529 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk30
1 files changed, 13 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index a93583bf74..a7084c8d07 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -10,25 +10,25 @@ OTHER_MENU:=Other modules
WATCHDOG_DIR:=watchdog
-define KernelPackage/6lowpan-iphc
- USBMENU:=$(OTHER_MENU)
- TITLE:=6lowpan shared code
- KCONFIG:=CONFIG_6LOWPAN_IPHC
- HIDDEN:=1
- FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
- AUTOLOAD:=$(call Autoprobe,6lowpan_iphc)
+define KernelPackage/6lowpan
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=6LoWPAN shared code
+ KCONFIG:=CONFIG_6LOWPAN
+ FILES:=$(LINUX_DIR)/net/6lowpan/6lowpan.ko
+ AUTOLOAD:=$(call AutoProbe,6lowpan)
endef
-define KernelPackage/6lowpan-iphc/description
+define KernelPackage/6lowpan/description
Shared 6lowpan code for IEEE 802.15.4 and Bluetooth.
endef
-$(eval $(call KernelPackage,6lowpan-iphc))
+$(eval $(call KernelPackage,6lowpan))
+
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-6lowpan-iphc +kmod-lib-crc16 +kmod-hid
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-lib-crc16 +kmod-hid
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -70,13 +70,9 @@ $(eval $(call KernelPackage,bluetooth))
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
- DEPENDS:=+kmod-bluetooth
- KCONFIG:= \
- CONFIG_6LOWPAN=m \
- CONFIG_BT_6LOWPAN=m
- FILES:= \
- $(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko \
- $(LINUX_DIR)/net/6lowpan/6lowpan.ko
+ DEPENDS:=+kmod-6lowpan +kmod-bluetooth
+ KCONFIG:=CONFIG_BT_6LOWPAN
+ FILES:=$(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko
AUTOLOAD:=$(call AutoProbe,bluetooth)
endef