aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-10 11:52:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-10 11:52:54 +0000
commite4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd (patch)
tree4e404413f639957845d324aff3ca50790b8663e1 /package/kernel/linux/modules/other.mk
parentd4cdd37e211c83ee781fdd7aec3273c32dd2b596 (diff)
downloadmaster-187ad058-e4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd.tar.gz
master-187ad058-e4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd.tar.bz2
master-187ad058-e4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd.zip
kernel: drop obsolete linux 3.10 related dependencies/checks
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk13
1 files changed, 5 insertions, 8 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3460a55b36..4696f2daec 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -13,7 +13,6 @@ WATCHDOG_DIR:=watchdog
define KernelPackage/6lowpan-iphc
USBMENU:=$(OTHER_MENU)
TITLE:=6lowpan shared code
- DEPENDS:=@!LINUX_3_10
KCONFIG:=CONFIG_6LOWPAN_IPHC
HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
@@ -29,7 +28,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16 +kmod-hid
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-6lowpan-iphc +kmod-lib-crc16 +kmod-hid
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -71,7 +70,7 @@ $(eval $(call KernelPackage,bluetooth))
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
- DEPENDS:=+kmod-bluetooth @!LINUX_3_10 @!LINUX_3_14
+ DEPENDS:=+kmod-bluetooth @!LINUX_3_14
KCONFIG:= \
CONFIG_6LOWPAN=m \
CONFIG_BT_6LOWPAN=m
@@ -740,7 +739,7 @@ $(eval $(call KernelPackage,ikconfig))
define KernelPackage/zram
SUBMENU:=$(OTHER_MENU)
TITLE:=ZRAM
- DEPENDS:=+kmod-lib-lzo +(!LINUX_3_10&&!LINUX_3_14):kmod-lib-lz4
+ DEPENDS:=+kmod-lib-lzo +!LINUX_3_14:kmod-lib-lz4
KCONFIG:= \
CONFIG_ZSMALLOC \
CONFIG_ZRAM \
@@ -749,10 +748,8 @@ define KernelPackage/zram
CONFIG_ZSMALLOC_STAT=n \
CONFIG_ZRAM_LZ4_COMPRESS=y
FILES:= \
- $(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko@lt3.14 \
- $(LINUX_DIR)/drivers/staging/zram/zram.ko@lt3.14 \
- $(LINUX_DIR)/mm/zsmalloc.ko@ge3.14 \
- $(LINUX_DIR)/drivers/block/zram/zram.ko@ge3.14
+ $(LINUX_DIR)/mm/zsmalloc.ko \
+ $(LINUX_DIR)/drivers/block/zram/zram.ko
AUTOLOAD:=$(call AutoLoad,20,zsmalloc zram)
endef