aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-04 20:25:13 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-07-04 20:25:13 +0200
commitd818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e (patch)
tree7d0b6d34fb4414684d233b8ee9f10c5ea7925a2b /package/kernel/linux/modules/other.mk
parenta1f8d578031ef765d873fde6f6722fc506176eb5 (diff)
downloadmaster-187ad058-d818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e.tar.gz
master-187ad058-d818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e.tar.bz2
master-187ad058-d818da7f77c8cd7fe8e66fb2e2ecd0590b1e9e8e.zip
mvebu: enable core drivers in the kernel config instead of packaging them
Simplify profile package selection Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk40
1 files changed, 3 insertions, 37 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 503ca98be4..42b45ba893 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -501,7 +501,7 @@ $(eval $(call KernelPackage,wdt-omap))
define KernelPackage/wdt-orion
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell Orion Watchdog timer
- DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
+ DEPENDS:=@TARGET_orion||TARGET_kirkwood
KCONFIG:=CONFIG_ORION_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
AUTOLOAD:=$(call AutoLoad,50,orion_wdt,1)
@@ -585,7 +585,7 @@ $(eval $(call KernelPackage,rtc-isl1208))
define KernelPackage/rtc-marvell
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell SoC built-in RTC support
- DEPENDS:=@RTC_SUPPORT @TARGET_kirkwood||TARGET_orion||TARGET_mvebu
+ DEPENDS:=@RTC_SUPPORT @TARGET_kirkwood||TARGET_orion
KCONFIG:=CONFIG_RTC_DRV_MV \
CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
@@ -599,23 +599,6 @@ endef
$(eval $(call KernelPackage,rtc-marvell))
-define KernelPackage/rtc-armada38x
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Marvell Armada 38x SoC built-in RTC support
- DEPENDS:=@RTC_SUPPORT @TARGET_mvebu
- KCONFIG:=CONFIG_RTC_DRV_ARMADA38X \
- CONFIG_RTC_CLASS=y
- FILES:=$(LINUX_DIR)/drivers/rtc/rtc-armada38x.ko
- AUTOLOAD:=$(call AutoProbe,rtc-armada38x)
-endef
-
-define KernelPackage/rtc-armada38x/description
- Kernel module for Marvell Armada 38x SoC built-in RTC.
-endef
-
-$(eval $(call KernelPackage,rtc-armada38x))
-
-
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support
@@ -794,7 +777,7 @@ $(eval $(call KernelPackage,zram))
define KernelPackage/mvsdio
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell SDIO support
- DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu +kmod-mmc
+ DEPENDS:=@TARGET_orion||TARGET_kirkwood +kmod-mmc
KCONFIG:=CONFIG_MMC_MVSDIO
FILES:=$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
AUTOLOAD:=$(call AutoProbe,mvsdio)
@@ -936,23 +919,6 @@ endef
$(eval $(call KernelPackage,thermal))
-define KernelPackage/thermal-armada
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Armada 370/XP thermal management
- DEPENDS:=@TARGET_mvebu +kmod-thermal
- KCONFIG:=CONFIG_ARMADA_THERMAL
- FILES:=$(LINUX_DIR)/drivers/thermal/armada_thermal.ko
- AUTOLOAD:=$(call AutoProbe,armada_thermal)
-endef
-
-define KernelPackage/thermal-armada/description
- Enable this module if you want to have support for thermal management
- controller present in Armada 370 and Armada XP SoC.
-endef
-
-$(eval $(call KernelPackage,thermal-armada))
-
-
define KernelPackage/thermal-imx
SUBMENU:=$(OTHER_MENU)
TITLE:=Temperature sensor driver for Freescale i.MX SoCs