aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-19 11:59:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-19 11:59:17 +0000
commitc5cbae5e1c2c587e53104e914ccb87a9849e08a9 (patch)
treea7604421d55a173490f47d729d5728d4c23ff561 /package/kernel/linux/modules/other.mk
parent1f2abeb61b0f1eda710a9d7bc7ec01ebdfbd569c (diff)
downloadmaster-187ad058-c5cbae5e1c2c587e53104e914ccb87a9849e08a9.tar.gz
master-187ad058-c5cbae5e1c2c587e53104e914ccb87a9849e08a9.tar.bz2
master-187ad058-c5cbae5e1c2c587e53104e914ccb87a9849e08a9.zip
kernel: remove obsolete kernel version dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44892 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 57f682d1d5..c39c1ab64f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -13,7 +13,7 @@ WATCHDOG_DIR:=watchdog
define KernelPackage/6lowpan-iphc
USBMENU:=$(OTHER_MENU)
TITLE:=6lowpan shared code
- DEPENDS:=@!LINUX_3_8 @!LINUX_3_10 @!LINUX_3_13
+ DEPENDS:=@!LINUX_3_10
KCONFIG:=CONFIG_6LOWPAN_IPHC
HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +(!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13):kmod-6lowpan-iphc
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -73,7 +73,7 @@ $(eval $(call KernelPackage,bluetooth))
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
- DEPENDS:=+kmod-bluetooth @!(LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
+ DEPENDS:=+kmod-bluetooth @!LINUX_3_10 @!LINUX_3_14
KCONFIG:= \
CONFIG_6LOWPAN=m \
CONFIG_BT_6LOWPAN=m
@@ -696,7 +696,7 @@ define KernelPackage/serial-8250
CONFIG_SERIAL_8250_SHARE_IRQ=y \
CONFIG_SERIAL_8250_DETECT_IRQ=n \
CONFIG_SERIAL_8250_RSA=n
- FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250$(if $(CONFIG_LINUX_3_8),_core).ko
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
endef
define KernelPackage/serial-8250/description
@@ -746,7 +746,7 @@ $(eval $(call KernelPackage,ikconfig))
define KernelPackage/zram
SUBMENU:=$(OTHER_MENU)
TITLE:=ZRAM
- DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx +(!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13&&!LINUX_3_14):kmod-lib-lz4
+ DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx +(!LINUX_3_10&&!LINUX_3_14):kmod-lib-lz4
KCONFIG:= \
CONFIG_ZSMALLOC \
CONFIG_ZRAM \