aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:10:20 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:10:20 +0000
commitac13fc7961036b793148a430222395b69878e528 (patch)
tree42616e11b2836854baffed99f14aacf67b3cfada /package/kernel/linux/modules/other.mk
parent51a317cc75812149fd3e5b1ae1182808dbe9b65a (diff)
downloadmaster-187ad058-ac13fc7961036b793148a430222395b69878e528.tar.gz
master-187ad058-ac13fc7961036b793148a430222395b69878e528.tar.bz2
master-187ad058-ac13fc7961036b793148a430222395b69878e528.zip
kernel: add ath3k module package
Adds a package for the ath3k kernel module, present in 3.18/4.0/4.1 kernels Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47223 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d438fbe7df..9ff291dd0f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -78,6 +78,25 @@ endef
$(eval $(call KernelPackage,bluetooth))
+define KernelPackage/ath3k
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ATH3K Kernel Module support
+ DEPENDS:=+kmod-bluetooth +ar3k-firmware
+ KCONFIG:= \
+ CONFIG_BT_ATH3K \
+ CONFIG_BT_HCIUART_ATH3K
+ $(call AddDepends/bluetooth)
+ FILES:= \
+ $(LINUX_DIR)/drivers/bluetooth/ath3k.ko
+ AUTOLOAD:=$(call AutoProbe,ath3k)
+endef
+
+define KernelPackage/ath3k/description
+ Kernel support for ATH3K Module
+endef
+
+$(eval $(call KernelPackage,ath3k))
+
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)