aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-11 10:43:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-11 10:43:46 +0000
commita2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a (patch)
tree52d06032c07770d04c1e55e839aaeb7f10cf4001 /package/kernel/linux/modules/other.mk
parent2b0dd36cddc7ae4a59cb5661b054d56e590727f0 (diff)
downloadmaster-187ad058-a2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a.tar.gz
master-187ad058-a2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a.tar.bz2
master-187ad058-a2b45c4a8375070c1eaa2d4c30e89d2d56a29b1a.zip
kernel: remove kernel module checks/dependencies for 3.14
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45377 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 4696f2daec..bfdda2c389 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -70,7 +70,7 @@ $(eval $(call KernelPackage,bluetooth))
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
- DEPENDS:=+kmod-bluetooth @!LINUX_3_14
+ DEPENDS:=+kmod-bluetooth
KCONFIG:= \
CONFIG_6LOWPAN=m \
CONFIG_BT_6LOWPAN=m
@@ -739,7 +739,7 @@ $(eval $(call KernelPackage,ikconfig))
define KernelPackage/zram
SUBMENU:=$(OTHER_MENU)
TITLE:=ZRAM
- DEPENDS:=+kmod-lib-lzo +!LINUX_3_14:kmod-lib-lz4
+ DEPENDS:=+kmod-lib-lzo +kmod-lib-lz4
KCONFIG:= \
CONFIG_ZSMALLOC \
CONFIG_ZRAM \
@@ -966,8 +966,7 @@ define KernelPackage/echo
SUBMENU:=$(OTHER_MENU)
TITLE:=Line Echo Canceller
KCONFIG:=CONFIG_ECHO
- FILES:=$(LINUX_DIR)/drivers/staging/echo/echo.ko@lt3.18 \
- $(LINUX_DIR)/drivers/misc/echo/echo.ko@ge3.18
+ FILES:=$(LINUX_DIR)/drivers/misc/echo/echo.ko
AUTOLOAD:=$(call AutoLoad,50,echo)
endef