aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-02 14:32:07 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-02 14:32:07 +0000
commit9a8824c9932b7a77f9eeb6b4759e14f2b7a258fd (patch)
tree0bd12f2af5df7a59674028628e654757e96c4972 /package/kernel/linux/modules/other.mk
parenta1743548d0218ad52dd4db62dfc4a9f90970308a (diff)
downloadmaster-187ad058-9a8824c9932b7a77f9eeb6b4759e14f2b7a258fd.tar.gz
master-187ad058-9a8824c9932b7a77f9eeb6b4759e14f2b7a258fd.tar.bz2
master-187ad058-9a8824c9932b7a77f9eeb6b4759e14f2b7a258fd.zip
kernel: watchdog modules should be loaded on boot
Otherwise procd cannot initialize the watchdog since the module will be loaded later. Tested with booke_wdt. Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45239 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 20964f5287..36d3ef9e96 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -468,7 +468,7 @@ define KernelPackage/wdt-omap
DEPENDS:=@(TARGET_omap24xx||TARGET_omap35xx)
KCONFIG:=CONFIG_OMAP_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,omap_wdt.ko)
+ AUTOLOAD:=$(call AutoLoad,50,omap_wdt.ko,1)
endef
define KernelPackage/wdt-omap/description
@@ -484,7 +484,7 @@ define KernelPackage/wdt-orion
DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
KCONFIG:=CONFIG_ORION_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
+ AUTOLOAD:=$(call AutoLoad,50,orion_wdt,1)
endef
define KernelPackage/wdt-orion/description
@@ -500,7 +500,7 @@ define KernelPackage/booke-wdt
DEPENDS:=@(TARGET_mpc85xx||TARGET_ppc40x||TARGET_ppc44x)
KCONFIG:=CONFIG_BOOKE_WDT
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/booke_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,booke_wdt)
+ AUTOLOAD:=$(call AutoLoad,50,booke_wdt,1)
endef
define KernelPackage/booke-wdt/description