aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-22 12:02:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-22 12:02:11 +0000
commit8ea70ab125393439df317c018a7aa6ce3fcb71c8 (patch)
treed761e334923dad90bb89fb9eb07cdfc443df0a79 /package/kernel/linux/modules/other.mk
parent524c7f55b41993630eedb82393ba915a40445886 (diff)
downloadmaster-187ad058-8ea70ab125393439df317c018a7aa6ce3fcb71c8.tar.gz
master-187ad058-8ea70ab125393439df317c018a7aa6ce3fcb71c8.tar.bz2
master-187ad058-8ea70ab125393439df317c018a7aa6ce3fcb71c8.zip
kernel: Add kernel module for Freescale SNVS RTC on chip module
Signed-off-by: Petr Štetiar <ynezz@true.cz> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48454 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b244fbe538..528d32f0b7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -666,6 +666,22 @@ endef
$(eval $(call KernelPackage,rtc-pt7c4338))
+define KernelPackage/rtc-snvs
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Freescale SNVS RTC support
+ DEPENDS:=@TARGET_imx6 @RTC_SUPPORT
+ KCONFIG:=CONFIG_RTC_DRV_SNVS \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-snvs.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-snvs,1)
+endef
+
+define KernelPackage/rtc-snvs/description
+ Kernel module for Freescale SNVS RTC on chip module
+endef
+
+$(eval $(call KernelPackage,rtc-snvs))
+
define KernelPackage/mtdtests
SUBMENU:=$(OTHER_MENU)