aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-10-28 06:47:20 +0000
committerJohn Crispin <blogic@openwrt.org>2013-10-28 06:47:20 +0000
commit7eccc12250a6afb542f87f1803d650f7e1a585c6 (patch)
treeb124b0dfc5a2f1aa4989d124411509d6fb4d425b /package/kernel/linux/modules/other.mk
parent5334c569415cf0f0acb7e5d58fe0e74f3e899303 (diff)
downloadmaster-187ad058-7eccc12250a6afb542f87f1803d650f7e1a585c6.tar.gz
master-187ad058-7eccc12250a6afb542f87f1803d650f7e1a585c6.tar.bz2
master-187ad058-7eccc12250a6afb542f87f1803d650f7e1a585c6.zip
kernel: add packages for sdhci support
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38549 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk23
1 files changed, 22 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 453bedfc20..428bde6529 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -265,7 +265,6 @@ define KernelPackage/mmc
CONFIG_MMC_DEBUG=n \
CONFIG_MMC_UNSAFE_RESUME=n \
CONFIG_MMC_BLOCK_BOUNCE=y \
- CONFIG_MMC_SDHCI=n \
CONFIG_MMC_TIFM_SD=n \
CONFIG_MMC_WBSD=n \
CONFIG_SDIO_UART=n
@@ -282,6 +281,28 @@ endef
$(eval $(call KernelPackage,mmc))
+define KernelPackage/sdhci
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Secure Digital Host Controller Interface support
+ DEPENDS:=+kmod-mmc
+ KCONFIG:= \
+ CONFIG_MMC_SDHCI \
+ CONFIG_MMC_SDHCI_PLTFM \
+ CONFIG_MMC_SDHCI_PCI=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/mmc/host/sdhci.ko \
+ $(LINUX_DIR)/drivers/mmc/host/sdhci-pltfm.ko
+
+ AUTOLOAD:=$(call AutoProbe,sdhci sdhci-pltfm,1)
+endef
+
+define KernelPackage/sdhci/description
+ Kernel support for SDHCI Hosts
+endef
+
+$(eval $(call KernelPackage,sdhci))
+
+
define KernelPackage/oprofile
SUBMENU:=$(OTHER_MENU)
TITLE:=OProfile profiling support