aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:35 +0000
commit66d3fcf859c9880145cb6bcf4181741ed6908e3b (patch)
tree995625e088960cfb1dee68d08e7ece4f0a181bb4 /package/kernel/linux/modules/other.mk
parent7e57d6c694a7fa124ab7790ffbc360b7f712fdd2 (diff)
downloadmaster-187ad058-66d3fcf859c9880145cb6bcf4181741ed6908e3b.tar.gz
master-187ad058-66d3fcf859c9880145cb6bcf4181741ed6908e3b.tar.bz2
master-187ad058-66d3fcf859c9880145cb6bcf4181741ed6908e3b.zip
package/kernel: add support for industrial-io and AD799x
Add support for industrial IO core and (still staging) driver for AD799x, a high precision I2C ADC family. Signed-off-by: Hartmut Knaack <knaack.h@gmx.de> [juhosg: update subject, reformat commit message] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38187 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b2d59560f3..293e517821 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -193,6 +193,51 @@ endef
$(eval $(call KernelPackage,gpio-pcf857x))
+define KernelPackage/iio-core
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@!LINUX_3_3
+ TITLE:=Industrial IO core
+ KCONFIG:= \
+ CONFIG_IIO \
+ CONFIG_IIO_BUFFER=y \
+ CONFIG_IIO_KFIFO_BUF \
+ CONFIG_IIO_TRIGGER=y \
+ CONFIG_IIO_TRIGGERED_BUFFER
+ FILES:= \
+ $(LINUX_DIR)/drivers/iio/industrialio.ko \
+ $(LINUX_DIR)/drivers/iio/industrialio-triggered-buffer.ko \
+ $(LINUX_DIR)/drivers/iio/kfifo_buf.ko
+ AUTOLOAD:=$(call AutoLoad,55,industrialio kfifo_buf industrialio-triggered-buffer)
+endef
+
+define KernelPackage/iio-core/description
+ The industrial I/O subsystem provides a unified framework for
+ drivers for many different types of embedded sensors using a
+ number of different physical interfaces (i2c, spi, etc)
+endef
+
+$(eval $(call KernelPackage,iio-core))
+
+
+define KernelPackage/iio-ad799x
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=kmod-i2c-core kmod-iio-core
+ TITLE:=Analog Devices AD799x ADC driver
+ KCONFIG:= \
+ CONFIG_AD799X_RING_BUFFER=y \
+ CONFIG_AD799X
+ FILES:=$(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko
+ AUTOLOAD:=$(call AutoLoad,56,ad799x)
+endef
+
+define KernelPackage/iio-ad799x/description
+ support for Analog Devices:
+ ad7991, ad7995, ad7999, ad7992, ad7993, ad7994, ad7997, ad7998
+ i2c analog to digital converters (ADC). WARNING! This driver is still staging!
+endef
+
+$(eval $(call KernelPackage,iio-ad799x))
+
define KernelPackage/lp
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port and line printer support