aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:23 +0000
commit4b86893200de6f1aa9d76578de43c8aa9f5de132 (patch)
tree451d3633f3f234d251d93f861e6a4bda8e005897 /package/kernel/linux/modules/other.mk
parentbdf3aed1173c631822eed37b28ea240c6017c6b4 (diff)
downloadmaster-187ad058-4b86893200de6f1aa9d76578de43c8aa9f5de132.tar.gz
master-187ad058-4b86893200de6f1aa9d76578de43c8aa9f5de132.tar.bz2
master-187ad058-4b86893200de6f1aa9d76578de43c8aa9f5de132.zip
kernel: remove useless AddDepends/crc16 abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45133 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 86770b5a3b..1644f77ce4 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -50,7 +50,6 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIUART_H4 \
CONFIG_BT_HIDP \
CONFIG_HID_SUPPORT=y
- $(call AddDepends/crc16)
$(call AddDepends/hid)
$(call AddDepends/rfkill)
FILES:= \