aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 13:06:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 13:06:34 +0000
commit412d1e64ea97435ca15996b754a3c20c2d382965 (patch)
tree201035cbbd71ddd8c3ec78f233376c9ab9c86c91 /package/kernel/linux/modules/other.mk
parent4c0754e53349878e5551713be464bb42cb99a59f (diff)
downloadmaster-187ad058-412d1e64ea97435ca15996b754a3c20c2d382965.tar.gz
master-187ad058-412d1e64ea97435ca15996b754a3c20c2d382965.tar.bz2
master-187ad058-412d1e64ea97435ca15996b754a3c20c2d382965.zip
mvebu: add support for the in-CPU RTC on the Armada 38x
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45415 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index bfdda2c389..a93583bf74 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -573,6 +573,23 @@ endef
$(eval $(call KernelPackage,rtc-marvell))
+
+define KernelPackage/rtc-armada38x
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell Armada 38x SoC built-in RTC support
+ DEPENDS:=@RTC_SUPPORT @TARGET_mvebu
+ KCONFIG:=CONFIG_RTC_DRV_ARMADA38X
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-armada38x.ko
+ AUTOLOAD:=$(call AutoProbe,rtc-armada38x)
+endef
+
+define KernelPackage/rtc-armada38x/description
+ Kernel module for Marvell Armada 38x SoC built-in RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-armada38x))
+
+
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support