aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-17 09:29:34 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-17 09:29:34 +0000
commit3cd6efc5016d5d1d8cbdcfd64af83e310fcbc1dd (patch)
treee9a05010668417155b19afb19f7524294c8f9fa3 /package/kernel/linux/modules/other.mk
parent0007bb9f1edb182c53eeb611978f5507d7dfb9e0 (diff)
downloadmaster-187ad058-3cd6efc5016d5d1d8cbdcfd64af83e310fcbc1dd.tar.gz
master-187ad058-3cd6efc5016d5d1d8cbdcfd64af83e310fcbc1dd.tar.bz2
master-187ad058-3cd6efc5016d5d1d8cbdcfd64af83e310fcbc1dd.zip
kernel: kmod-ptp selects a new config symbol
since Kernel 3.14 408eccce net: ptp: move PTP classifier in its own file found while bug search thx olmari on IRC Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47923 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9bb9dec2bc..62fdc3cd69 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -820,7 +820,9 @@ define KernelPackage/ptp
SUBMENU:=$(OTHER_MENU)
TITLE:=PTP clock support
DEPENDS:=+kmod-pps
- KCONFIG:=CONFIG_PTP_1588_CLOCK
+ KCONFIG:= \
+ CONFIG_PTP_1588_CLOCK \
+ CONFIG_NET_PTP_CLASSIFY=y
FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
AUTOLOAD:=$(call AutoLoad,18,ptp,1)
endef