aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:59:03 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:59:03 +0000
commit3609351bdee061722deea92460c17bbda70c7851 (patch)
tree96f8eb0c4d7e4f146cb6d8175b5d0e82921d832d /package/kernel/linux/modules/other.mk
parent884842d5d27e63a1b0fed0c3325d06bda3e65343 (diff)
downloadmaster-187ad058-3609351bdee061722deea92460c17bbda70c7851.tar.gz
master-187ad058-3609351bdee061722deea92460c17bbda70c7851.tar.bz2
master-187ad058-3609351bdee061722deea92460c17bbda70c7851.zip
linux: kmod-zram requires kmod-lib-lz4 for >= 3.15
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44205 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 59d2e2c1aa..a69d817ed3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -748,7 +748,7 @@ $(eval $(call KernelPackage,ikconfig))
define KernelPackage/zram
SUBMENU:=$(OTHER_MENU)
TITLE:=ZRAM
- DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx
+ DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx +(!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13&&!LINUX_3_14):kmod-lib-lz4
KCONFIG:= \
CONFIG_ZSMALLOC \
CONFIG_ZRAM \