aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-09-13 20:35:10 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-09-13 20:35:10 +0000
commit35941f423b204d17dcaa811aea043b3376b5d634 (patch)
tree856b46d567928ddbc516d983488e67a5fb14ae8d /package/kernel/linux/modules/other.mk
parent0e4a30a311ec76db382c1d05b62b349f74fc019c (diff)
downloadmaster-187ad058-35941f423b204d17dcaa811aea043b3376b5d634.tar.gz
master-187ad058-35941f423b204d17dcaa811aea043b3376b5d634.tar.bz2
master-187ad058-35941f423b204d17dcaa811aea043b3376b5d634.zip
package: other.mk: update configuration for ad799x
The ad799x driver moved out of staging since kernel 3.16, so update filepath, config elements and description. Signed-off-by: Hartmut Knaack <knaack.h@gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42524 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 2f6f774e1f..199e4573f3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -242,14 +242,18 @@ define KernelPackage/iio-ad799x
KCONFIG:= \
CONFIG_AD799X_RING_BUFFER=y \
CONFIG_AD799X
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
+ FILES:=$(LINUX_DIR)/drivers/iio/adc/ad799x.ko
+else
FILES:=$(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko
+endif
AUTOLOAD:=$(call AutoLoad,56,ad799x)
endef
define KernelPackage/iio-ad799x/description
support for Analog Devices:
ad7991, ad7995, ad7999, ad7992, ad7993, ad7994, ad7997, ad7998
- i2c analog to digital converters (ADC). WARNING! This driver is still staging!
+ i2c analog to digital converters (ADC).
endef
$(eval $(call KernelPackage,iio-ad799x))