aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-10-20 00:00:39 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-10-20 00:00:39 +0000
commit326456486c5ab022bceb3137f72b15dae9476c94 (patch)
treeed0d8d44ec75727a8767bc3fca7b1d8035f0c700 /package/kernel/linux/modules/other.mk
parentefae73de2c7cdbe2ca6576be234b301286e96042 (diff)
downloadmaster-187ad058-326456486c5ab022bceb3137f72b15dae9476c94.tar.gz
master-187ad058-326456486c5ab022bceb3137f72b15dae9476c94.tar.bz2
master-187ad058-326456486c5ab022bceb3137f72b15dae9476c94.zip
kernel: force CONFIG_BT_HCIUART_ATH3K to y
The CONFIG_BT_HCIUART_ATH3K may not be "m", therfore we cannot inherit the kmod selection state. Force the "CONFIG_BT_HCIUART_ATH3K" symbol to "y" in order to avoid `warning: symbol value 'm' invalid for BT_HCIUART_ATH3K` and subsequent kconfig stalls. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47237 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9ff291dd0f..022410f2be 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -84,7 +84,7 @@ define KernelPackage/ath3k
DEPENDS:=+kmod-bluetooth +ar3k-firmware
KCONFIG:= \
CONFIG_BT_ATH3K \
- CONFIG_BT_HCIUART_ATH3K
+ CONFIG_BT_HCIUART_ATH3K=y
$(call AddDepends/bluetooth)
FILES:= \
$(LINUX_DIR)/drivers/bluetooth/ath3k.ko