aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-10 11:52:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-10 11:52:54 +0000
commite4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd (patch)
tree4e404413f639957845d324aff3ca50790b8663e1 /package/kernel/linux/modules/netsupport.mk
parentd4cdd37e211c83ee781fdd7aec3273c32dd2b596 (diff)
downloadmaster-187ad058-e4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd.tar.gz
master-187ad058-e4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd.tar.bz2
master-187ad058-e4c60f7dc3d5a5914ab0302e76bea70c6e7a6cdd.zip
kernel: drop obsolete linux 3.10 related dependencies/checks
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 0d70a88a05..60e3094c20 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -148,7 +148,7 @@ $(eval $(call KernelPackage,8021q))
define KernelPackage/udptunnel4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv4 UDP tunneling support
- DEPENDS:=@!LINUX_3_10 @!LINUX_3_14
+ DEPENDS:=@!LINUX_3_14
KCONFIG:=CONFIG_NET_UDP_TUNNEL
FILES:=$(LINUX_DIR)/net/ipv4/udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,udp_tunnel)
@@ -160,7 +160,7 @@ $(eval $(call KernelPackage,udptunnel4))
define KernelPackage/udptunnel6
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv6 UDP tunneling support
- DEPENDS:=@!LINUX_3_10 @!LINUX_3_14
+ DEPENDS:=@!LINUX_3_14
KCONFIG:=CONFIG_NET_UDP_TUNNEL
FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
@@ -174,8 +174,8 @@ define KernelPackage/vxlan
TITLE:=Native VXLAN Kernel support
DEPENDS:= \
+kmod-iptunnel \
- +(!LINUX_3_10&&!LINUX_3_14):kmod-udptunnel4 \
- +(!LINUX_3_10&&!LINUX_3_14&&IPV6):kmod-udptunnel6
+ +!LINUX_3_14:kmod-udptunnel4 \
+ +(!LINUX_3_14&&IPV6):kmod-udptunnel6
KCONFIG:=CONFIG_VXLAN
FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
AUTOLOAD:=$(call AutoLoad,13,vxlan)
@@ -863,8 +863,8 @@ define KernelPackage/l2tp
TITLE:=Layer Two Tunneling Protocol (L2TP)
DEPENDS:= \
+IPV6:kmod-ipv6 \
- +(!LINUX_3_10&&!LINUX_3_14):kmod-udptunnel4 \
- +(!LINUX_3_10&&!LINUX_3_14&&IPV6):kmod-udptunnel6
+ +!LINUX_3_14:kmod-udptunnel4 \
+ +(!LINUX_3_14&&IPV6):kmod-udptunnel6
KCONFIG:=CONFIG_L2TP \
CONFIG_L2TP_V3=y \
CONFIG_L2TP_DEBUGFS=n