aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-05-05 13:22:33 +0000
committerSteven Barth <steven@midlink.org>2015-05-05 13:22:33 +0000
commitdcf8ac794b77b8de9f1ea017b07b47e69112e0f7 (patch)
tree2d8abd8ea50cdde70215803cd82f091038868452 /package/kernel/linux/modules/netsupport.mk
parent72931f3946d24bb32cb589a0f7b55e52711d2840 (diff)
downloadmaster-187ad058-dcf8ac794b77b8de9f1ea017b07b47e69112e0f7.tar.gz
master-187ad058-dcf8ac794b77b8de9f1ea017b07b47e69112e0f7.tar.bz2
master-187ad058-dcf8ac794b77b8de9f1ea017b07b47e69112e0f7.zip
netsupport: l2tp-ip: only depend on IPv6 if IPv6 support is enabled
Before r45593 kmod-l2tp-ip did not depend on kmod-ipv6. With r45593 support for L2TP IPv6 encapsulation was added and included in the kmod-l2tp-ip package. This change also added the dependency to kmod-ipv6 to kmod-l2tp-ip, regardless of whether the user chose to generally include IPv6 support or not. Change this so L2TP over IPv6 and the resulting dependency to kmod-ipv6 is only included in kmod-l2tp-ip if IPv6 support is enabled. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45612 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 7ec3d29792..4483581bf4 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -895,11 +895,13 @@ $(eval $(call KernelPackage,l2tp-eth))
define KernelPackage/l2tp-ip
SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=L2TP IP + IPv6 encapsulation for L2TPv3
- DEPENDS:=+kmod-l2tp +kmod-ipv6
+ TITLE:=L2TP IP encapsulation for L2TPv3
+ DEPENDS:=+kmod-l2tp +IPV6:kmod-ipv6
KCONFIG:=CONFIG_L2TP_IP
- FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.ko $(LINUX_DIR)/net/l2tp/l2tp_ip6.ko
- AUTOLOAD:=$(call AutoLoad,33,l2tp_ip l2tp_ip6)
+ FILES:= \
+ $(LINUX_DIR)/net/l2tp/l2tp_ip.ko \
+ $(if $(CONFIG_IPV6),$(LINUX_DIR)/net/l2tp/l2tp_ip6.ko)
+ AUTOLOAD:=$(call AutoLoad,33,l2tp_ip $(if $(CONFIG_IPV6),l2tp_ip6))
endef
define KernelPackage/l2tp-ip/description