aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-18 16:49:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-18 16:49:55 +0000
commitbb6f01cacae3f3c10cb9f9af1afb462fce8ae056 (patch)
tree690cfeac17bc4eb417627d286aba07ae4f4c6880 /package/kernel/linux/modules/netsupport.mk
parent97029045040629c8eadb8aca617f51290b7fe105 (diff)
downloadmaster-187ad058-bb6f01cacae3f3c10cb9f9af1afb462fce8ae056.tar.gz
master-187ad058-bb6f01cacae3f3c10cb9f9af1afb462fce8ae056.tar.bz2
master-187ad058-bb6f01cacae3f3c10cb9f9af1afb462fce8ae056.zip
kernel: fix accidental depends line duplication
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37407 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 07ce47992c..c9740a945c 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -865,7 +865,6 @@ $(eval $(call KernelPackage,l2tp-ip))
define KernelPackage/sctp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=SCTP protocol kernel support
- DEPENDS:=+IPV6:kmod-ipv6
KCONFIG:=\
CONFIG_IP_SCTP \
CONFIG_SCTP_DBG_MSG=n \
@@ -880,7 +879,7 @@ define KernelPackage/sctp
CONFIG_SCTP_DEFAULT_COOKIE_HMAC_MD5=y
FILES:= $(LINUX_DIR)/net/sctp/sctp.ko
AUTOLOAD:= $(call AutoLoad,32,sctp)
- DEPENDS:=+kmod-lib-crc32c +kmod-crypto-md5 +kmod-crypto-hmac
+ DEPENDS:=+kmod-lib-crc32c +kmod-crypto-md5 +kmod-crypto-hmac +IPV6:kmod-ipv6
endef
define KernelPackage/sctp/description